Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Issues with 20.0.0 Release (Version Mismatch)
#1

Good Morning, has anybody else encountered issues with the new 20.0.0 release?

After upgrading, converting DB, running errors and omission reflects a mismatch with EdusolEmis.mdb being version 19.3.2
Troubleshooting steps in my own environment:

Tried replacing edusolemis.mdb with a renamed copy of edusolemis (20.0.0) file as per workaround I used to deploy on earlier versions     - No result
Tried removing the (20.0.0) named file    - threw an error that it was missing
Tried creating a brand new database, yielded an empty database of version 19.3.2 not 20.0.0 (Main window states SASAMS is version 20.0.0, but DB login prompt indicates DB version is 19.3.2)
Replicated on both Windows 10 as well as windows 8
Tried running as Administrator, Tried running in Compatibility mode for Win 7     -    No result
Removed absolutely every remnant of older files that could be found including the c:\users\[username]\appdata\virtualstore\program files\edusolsams diretory    - no result

It should be noted that the lab PC has never even seen version 19.3.2, only 19.3.0 so suspect perhaps 20.0.0 has shipped with 19.3.2 file?
Reply
#2

(08-17-2020, 10:32 AM)ednit Wrote:  Good Morning, has anybody else encountered issues with the new 20.0.0 release?

After upgrading, converting DB, running errors and omission reflects a mismatch with EdusolEmis.mdb being version 19.3.2
Troubleshooting steps in my own environment:

Tried replacing edusolemis.mdb with a renamed copy of edusolemis (20.0.0) file as per workaround I used to deploy on earlier versions     - No result
Tried removing the (20.0.0) named file    - threw an error that it was missing
Tried creating a brand new database, yielded an empty database of version 19.3.2 not 20.0.0 (Main window states SASAMS is version 20.0.0, but DB login prompt indicates DB version is 19.3.2)
Replicated on both Windows 10 as well as windows 8
Tried running as Administrator, Tried running in Compatibility mode for Win 7     -    No result
Removed absolutely every remnant of older files that could be found including the c:\users\[username]\appdata\virtualstore\program files\edusolsams diretory    - no result

It should be noted that the lab PC has never even seen version 19.3.2, only 19.3.0 so suspect perhaps 20.0.0 has shipped with 19.3.2 file?

Hi There

It might have not written the version history tables correctly (successfully) there is a way to manually enter the entries in the database directly. If you require assistance with this please mail your database compressed including the administrator password to [email protected] and I will gladly have a look at it for you Smile
Reply
#3

Thanks, problem is with the emis database though, not the clients'

I emailed them about it on the 12th, not sure when it went up but I see there is a patched emis db now downloadable from thutong website:

https://www.thutong.doe.gov.za/LinkClick...tabid=1570
Reply
#4

(08-17-2020, 10:32 AM)ednit Wrote:  Good Morning, has anybody else encountered issues with the new 20.0.0 release?

After upgrading, converting DB, running errors and omission reflects a mismatch with EdusolEmis.mdb being version 19.3.2
Troubleshooting steps in my own environment:

Tried replacing edusolemis.mdb with a renamed copy of edusolemis (20.0.0) file as per workaround I used to deploy on earlier versions     - No result
Tried removing the (20.0.0) named file    - threw an error that it was missing
Tried creating a brand new database, yielded an empty database of version 19.3.2 not 20.0.0 (Main window states SASAMS is version 20.0.0, but DB login prompt indicates DB version is 19.3.2)
Replicated on both Windows 10 as well as windows 8
Tried running as Administrator, Tried running in Compatibility mode for Win 7     -    No result
Removed absolutely every remnant of older files that could be found including the c:\users\[username]\appdata\virtualstore\program files\edusolsams diretory    - no result

It should be noted that the lab PC has never even seen version 19.3.2, only 19.3.0 so suspect perhaps 20.0.0 has shipped with 19.3.2 file?

Hi,

I have recieved the same error saying that there is a database mismatch.

Have you been able to figure anything out?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)